Renoise tracker related topics.

converting 1.9 modules to load in 1.8

converting 1.9 modules to load in 1.8

Postby plusminus » Sun Sep 23, 2007 2:27 pm

I don't actually have a renoise 1.9 module to try this out on, so I have no idea if it works. But for you guys who accidentally composed a tune in 1.9, it might be possible to force it to load in 1.8. It's doubtful, but this shouldn't take more than a few minutes to try.

First, edit your song in 1.9 to not use any features that aren't in 1.8, if this is at all possible. Save it in a different file so if something goes horribly wrong you're not overwriting your old song.

Then, make a copy of your file mysong.xrns to mysong.xrns.zip, and use Winzip or whatever to open up the zipfile. Extract the file song.xml.

Then you need something to edit this file. There's lots of funky xml editors around but for this job a text editor that can handle large files will probably do. (Not notepad!) I found something called NoteTab light at http://www.notetab.com/ntl.php that works.

In a renoise 1.8 file, the second line reads:
Code: Select all
<RenoiseSong doc_version="4">

Presumably in a renoise 1.9 file, doc_version is set to 5 or 5b or something that isn't 4. Just change it to 4, then save the file.

Add the song.xml back into mysong.xrns.zip, and rename it back to mysong.xrns.

Then cross your fingers and try opening it in 1.8!

I'd be surprised if this actually works, but if you guys are feeling adventurous and/or desparate, it might be worth a shot...
User avatar
plusminus
Regular
Regular
 
Posts: 88
Joined: Thu Mar 08, 2007 5:05 pm
Location: Ontario, Canada

Return to Renoise

Who is online

Users browsing this forum: No registered users and 1 guest